
MORPHEUS SET UP PROCEDURE   Robert Clark ANIM001 01 and 02
 Installation instructions
jjburton@gmail.com.
http://www.joshburton.com/projects/morpheusDocs.asp
 Set-up Project Folder:
1. File > Project Window
2.  2.	Click "New" > Name Your Project
3. 3.	Click "Folder" button > Navigate to your desired location > Click "Accept"
4.  4.	File > Set Project (Note: This step is absolutely necessary every time you are going to work on your project).
 Make sure the render is set to mental ray and set the texture pathing .
When you are animating in class make sure you have your textures installed and your Project is properly set up. This info sheet is relatively comprehensive in regards to what you need to do in order to get Morphy running properly. Please read the whole document several times thoroughly. 
BACK UP EVERYTHING! !!! I bet you do it for your music so please do it for your assignments and future career!
You should be working diligently- Consider that everything you do will be put into your portfolio and be seen by future employers.
Feel free to request additions and/or offer revision to this paper
[bookmark: _GoBack]IMPORTANT NOTE- Have only your NURBS Curves and Polygons box selected in the Show drop down menu in the view window that you will be animating in. This will prevent you from accidentally selecting joints that are supposed to be hidden but are occasionally selectable when keying .This can cause the Morphy  geometry to explode .
 SAVING 
 Goto File > Save Scene click on the box and Open Save Scene Options window .Click the Incremental save button .This will save your scene incrementally every time you ctrl+s so that you will not  end up with a corrupted scene that you have been working over continuously.

PREFERENCES
To restore default preferences go to Window> Settings/Preferences >Edit> Restore Default Settings. Only do this if you have reset too many other things and want to reset new from scratch
To turn off view cube Window> Preferences >ViewCube deselect  Show the ViewCube
In order to set up Step Tangents in your presets go to Preferences >Animation>Tangents > Default in Tangent Select Linear /Default out Tangent select Stepped
Update view – Open the window Preferences> Time Slider> Playback> Update View:> All This will update your view windows simultaneously so you can animate in the perspective window and receive immediate feedback from your camera view window. This is very handy for doing your posing and blocking. A good way to animate with a single monitor screen is to have a 3 window set up with the perspective view on the right and the graph editor on the left with the dope sheet on the bottom. Have a window torn off with the camera view that you can move around and minimize when you don’t need it.
To Change View Window Color  go to Window> Settings/Preferences >Color Settings>colors>General>3D Views>Background double click on the color box and select a darker color-The Morphy “AllAnimate “button is grey so a dark bg is preferable
Auto Key  go to Window> Settings/Preferences >Animation>Auto Key. Select it on .Auto key will save you time and make sure that everything you move is keyed properly. You have to make sure you are on the proper key when using this feature. It takes a bit of getting used and requires discipline but it is a good time saver  in the long run
Have the constrained y-axis drag selected (red arrow indicator at the top right of the window) in the Graph Editor to help keep your key spline editing on the proper frame in the timeline
Set Time Window> Settings/Preferences>Time Slider>Playback>Playback speed set this to Real-time [24 fps]


HELP –F1 Just in case your internet is down and you want to use the  Help feature You can install Help off line here 
http://usa.autodesk.com/adsk/servlet/index?siteID=123112&id=16278314&linkID=10809894

ADDING SHELF AND TEXTURE
 (NOTE- I have simplified this process for you. Go to your drop box and get the “ MASTER MORPHY FILE”  copy the maya file inside it and  replace your Libraries> Documents > maya  folder with the one provided from the drop box. This will give you your shelves and textures-Thank you Steven !)
OR – You could take the long route and do this-
Put the Morpheus textures folder in the source images folder of your project   -Texture >sourceimages  Put the -morpheusRig_v01_00 rig  in the scenes folder of your project Put the pref and scripts  folders that were in the zipped ScriptsAndShelves folder from Morphy your Maya folder
C:\Users\[your name]\Documents\maya\maya 2012  (My Documents)
  ADDING TEXTURES TO MORPHEUS IN MAYA
 To add eye color Open the Hypershade Window > Rendering Editors > Hypershade  Middle mouse click and hold on L_EyesSG1 and drag it down to the work area. Double click on the black circle to bring up the Attribute editor. Select the file5 tab and beside image name select the folder. In the open window select Textures and open the folder named  eyes. Select the color you want and select Open in the bottom right of the window. This adds the texture to the phong.Morpheus should now have the eye color you selected
 To add skin color Open the hypershade Window > Rendering Editors > Hypershade Middle mouse click and hold on miss_fast_skin_maya1 and drag it down to the work area. Double click on the circle to bring up the Attribute editor. Select the file3 tab and beside image name select the folder. In the open window select Textures and open the folder named skin. Select the color you want and select Open in the bottom right of the window. This adds the texture to the phong. Morpheus should now have the skin color you selected Open the attribute editor again and select lambert5 and under common MaterialAttributes to change the body suite color if you want
 RESIZE MORPHEUS  select the edge of the "MORPH -o-MATIC " and in the Channel box under mode select morph Re-size your character to whatever preference you like.
 ANIMATION  
To animate select   animate  under mode in the Morpheus_UI .Select the Auto Keyframe Toggleon the extreme bottom left  to animate on your selected keyframe without having to press "S" for every adjustment .This button automatically keys every move you make. Just make sure you are on your proper keyframe when you animate .Keep the Select curve objects and the Select Surface objects buttons on the Selection Mask Menu on the toolbar. Turn off the other 6 buttons .This prevents you from accidentally selecting bones and other non animateable objects that can wreck your animation
 PROPS and BACKGROUNDS
 If you make something new in your scene -NAME IT! Put it in a layer and name that layer so you can identify and hide it while you are animating. 
Attaching Objects to each other
(Shelf) Polygons >Combine. 
Setting up an image plane – In the view window  you want to use select View > Image Plane> Import Image… and select your image from the drop down menu. Use this for modeling additional environments and props for your scene.
  Delete History  goto Edit >Delete by Type > History
LAYERS
 The facial controllers can be distracting and can sometimes make it difficult to select the head controller while you animate. To hide them while doing body animation go to the Display tab at the bottom of the Channel Box and create a new layer. Select the controllers you want to hide and right click on your new layer and in the drop down menu select Add Selected Objects . Select the "V" in your layer in order to make what you selected disappears select it again to make them reappear. Double click to change the name. "T "means the layer is templated. This means you can see it but you cannot modify it" means the layer is a reference You can not select or modify it. This is a good way to work without clicking on anything else in your scene accidentally
 ADDING SCRIPTS
 Unzip the additional scripts and put them in the -documents >Maya> 2012 -x64 >scripts, folder. This puts the scripts where you need them in order for them to work Unzip the icon folder and put it in - documents >Maya> 2012 -x64>prefs>icons. This putsThe image icons on your shelf 
Note: Type rehash in MEL command line after changing scripts
 Adding scripts info-
http://www.creativecrash.com/tutorials/loading-scripts-in-maya-101
ADDITIONAL SCRIPTS for Morpheus
 zooToolBox  - does not work ( not figured out yet)
http://www.macaronikazoo.com/
 jtdParentUI
website Unavalable
 abSymMesh
Need to join website to get script
 http://www.creativecrash.com/ 
 autoTangent  -This is a must have .
http://www.comet-cartoons.com/melscript.php
 tweenMachine- This is a must have .
http://www.justinanimator.com/mel-tweenMachine.php
SHELF BUTTONS information 
 Morphy head connect – Used to connect a Morphy head to a new body
 Custom Facial Geo – Attaches objects to the skin of the face. They then become part of the painted skin weights and move with  the surrounding surface . Good for attaching warts and  horns .Select the object you want to attach t and the select  the nearest controller (with shift )  and then select the  Custom Facial Geo button Note-this allows only one attachment  per controller at a time.
Hair Geo -  select CUSTOMGEO on the MORPH-O_MATIC and then Select Hair  in the Channel Box then select the object you want to attach and then press the HAIRGEO. Your object should be attached .Good for hats and real funky hair.
Skin Body Mesh . Attaches objects to the body .Select the object you want to attach  and the select  the nearest controller (with shift )  and then select the  Skin Body Mesh. Allows only one attachment per controller at a time. Adds  the painted weights so be careful about what you attach.
B0Triggers. This button allows  you to use the ALL ( key all) button in the morp-o-matic  when you reference in more than one Morphy model into your scene . It updates the controllers with their own file name specific to each Morphy . After you referencing in your morphys select the BoTriggers button and in the Triggers window go to Avanced  - Udate All Triggers
Point Snap. Select the object and then then select the controller ( or another object) you want it to have aligned to and  press  the Point Snap Button to move the second object to the center of the first object at its  0,0,0 object center
Orient Snap Select the object then select the controller ( or another object) and then press  the Orient Snap Button to align the X,Y,Z of the first object relative to the X,Y,Z of the second. 
AUTOTANGENT - This will be helpful at the later stages of your animation as it helps flatten your tangents for a more smooth animation look and it also can flatten your Ease in and Ease outs to make them look more smooth or snappy. This button can also accentuate your antics as it creates custom overshoots on your graph editor.
tweenMachine- Helps make breakdown keys for your animation. Allows you to add breakdowns (blocking) along  your timeline with a single selection .You can also make groups and sets in your animation .Create a group for each character and sets for specific areas of your character like the spine or arm. This is handy to help block out overlap.
Set up of this button requires the use of the script editor.
Window>General Editors> script editor. In the editor type -
 tweenMachine;
Highlight the line, then select File-->Save Selected to Shelf to turn it into a shelf button. Use the Shelf Editor to assign the icon to the shelf button. To start the tweenMachine, just click the button.
CUSTOM BUTTON  To add a selection to your shelf and make a custom button  select Ctrl + Shift and then the selection you want –example ,cube -and it should instantly appear on your shelf as a button 
IKFK Selection  Select the double-sided arrow at the wrist of Morpheus and in the Channel box go to IKFK and you will see a "0"  beside the indicator. this is FK . Input a ”1" in the box and this will give you  IK
 IK -Inverse Kinematics .Joints are controlled at the end of the joint chain and movement of the parent is calculated from the relative position of the child (the hand). You move the hand and the shoulder and elbow calculations follow (the parent). Using IK is ideal for attaching objects to the hand and animating with the wrist controller as apposed to animating from the shoulder and elbow with  FK 
 FK -Forward Kinematics . Joints are controlled by the parent (the shoulder) and the child(the hand) is unaffected relative to object in world space. Movements are calculated from the shoulder .The arm and hand obey the parent object calculations  and act like a solid object hinged from the shoulder.  Consider using IK arms if your Character is holding on to, or throwing something.
Attaching an object to the hand in IK  
Select the double sided arrow on the wrist and In the  IKFK selection select the box controller on the wrist then press shift and select the object you want to attach .This makes the box controller the parent and the object the child. Then open the Hotbox> Constrain >  Parent .Make sure your  Constraint axes are slected as All In the Parent Constraint Options  window  .                     
 HOW TO OFFSET USING THE DOPESHEET
 Select Panels > Dope Sheet
Select only the controllers you want to effect on Morpheus when you are doing your offsets. They will be labeled on your dope sheet summary on the left of your window. Select a key and with the middle mouse and slide the desired key forward or backward to apply the offset. The timing in the Dopesheet will be reflected in your animation timeline.When you are setting your offsets in the dope sheet keep in mind that you will be adding delay to your movements and that sometioms only a one or two key shift is enough to create a realistic offset. Start your offsets from the torso to the outer limbs to create drag and weight.
REFERENCING IN MORPHEUS / MULTIPLE
File >create Reference> [ select your file]  Select “BO TRIGGERS”   In the pop up window select  > Advanced > Update All Triggers
Do this for each Morphy you import .Renaming each one in the Reference Options is a good idea too.
ANIMATION PROCESS
Set your start time to “1” in the timeline .Do not start with Zero
DON’T Key the blue Morphy Platform (the blue circle with four arrows that Morphy stands on )
DON’T Key the Morph-o-matic
It is a good idea to keep a separate window open dedicated to your camera and animate Morphy in your  perspective/UI window.
Ease in - Start Slow, End Fast. More keys at start than at the beginning, Acceleration
Ease out-starts fast, End Slow .More keys at end than at the beginning. Deceleration
MOVING HOLDS – Make sure you are putting moving holds in-between your action poses. If you don’t do this your animation will look mushy and weak. You just don’t go from pose to pose –there are breaks in the timing where your character will stop –but not freeze. You will need to have subtle movements included that react to the action in order to keep your animation looking realistic and alive.
Note- Do not Key or animate the Morphy base ( the blue circle with 4 arrows that Morphy stands on).You will only move this base when you are moving to a new location or making a large move (like a big jump or fall) that happens during a cut.
Animating  Morphy.
You must consider Balance, Weight ,Inertia , consistency and Motion in all your poses.
1- Start with the hips .All movement springs out from the action of the hips and spreads out to the extremities.
2- 2-Make sure your arcs are properly considered in your poses and reinforced with your blocking
3-Lead with the eyes then the head then the body. Offset this action with subtlety and care 
4-Choose a point of emphasis for every major action
5-Sketch out your posing to force structure into  your animation at an early stage  
6-Be aware of your ease in and ease out motion relative to your arcs.
7-Your poses and timing are paramount. do not advance to the next stage of the animation process without perfecting this stage first.
8-Start blocking your animation after your keys and timing are perfect. Do this stage with an emphasis on your arcs.
9-Establish your moving holds . This is where you will be keeping the animation snappy and quick .This process can be done in conjunction with your blocking.
10-With your Keys, timing, blocking and moving holds completed start inbetweening with linear interpolation turned on. Up to this point you should be using step tangents only.
11-Make notes and revisions at the end of every stage. Seriously .If you don't your animation will suffer.
12- Add manual breakdowns for things like hands and small arcs. These are not full breakdowns as you will not be keying the whole character at this stage ,only the parts you want to effect.
13-Start to do the offset process in your dope sheet at this stage.Add drag and leading action here (Adding offsets is optional) for speed you can use offsets to add life to your animation quickly  but if you want to do “Full” animation use only filly keyed poses for your breakdowns and create drag and offsets within the timing of the poses. 
14-In the Graph editor add smooth curves and delete unneeded keys- especially along your animation curves . This will be a long and tedious process so do it thoroughly and properly because this is where you add a lot of finesse and finish to your animation.
PLUGINS
Window> Settings /Preferences > Plug-in Manager. Here is where you will find a list of your Plugins for Maya and a menu of what has been loaded. Select the Auto load box  from the plug in manager window to add the Plugin you want and restart
RENDERING
Make sure you have mental ray selected in the Render Settings window . If you cannot see it in the drop down list  under Render Using  -Select  Mayatomr.mll from the Plug- in manager window. To render Morphy properly you also need your textures put in their respective folders (sourceimages)- Note tweenMachine will not work without mentalray
Playblast -  Right click on the Timeline > Playblast open the options and select the settings you want to use. Do this often to keep track of your progress. 
To render single frame Open the  Render Settings window and under the Common tab select File Output >image format : select either JPEG or Targa
It is a good idea to use the Filmgate option in your camera view window so that when you animate and render you know exactly what will be in you frame.
To render a sequence Make sure the Rendering option drop down tab is selected on the far left of the Main Menu Bar  .Go to the Render  drop down menu in the Main Menu Bar and select the Batch Render box . The mental ray Batch Render Option box will open and then select the Batch render button at the bottom. The image sequence should appear in the images  folder of your project
COMMONLY USED BUTTONS, PANELS AND STUFF

HELP -F1
 Dope Sheet /if greyed out Panels >Panel Editor >New Panel >Dope Sheet 
moving gizmo/ only if you want to move it relative to your object centre  insert key + LMB. Do not mess with the little blue circle under the gizmo in this mode. It resets the gizmo translations permanently and there are no setting to get it back
Resizing Gizmo -, +
Hypergraph - general (shelf) > Hypergraph
Smoothness  - 1,2,3 -Wireframe 4 
ctrl+a attribute editor
Shade -5
Undo -Z
Frame Selection -f
Object/Component Selection -F8
Duplicate-Ctrl=d





MAYA HOTKEY LIST

Maya Hotkeys - Keyboard Shortcuts

Snapping Operations:

Snap to curves c
Snap to grids x
Snap to points v
Move, Rotate, Scale Tool snapping j
Move, Rotate, Scale Tool relative snapping Shift+J

Painting Operations:

Flood with the current value Alt+f
Turn Show Wireframe on/off Alt+a
Turn Color Feedback on/off Alt+c
Toggle Reflection on/off Alt+r
Artisan Paint Operation marking menu u+LMB
Modify upper brush radius b
Modify lower brush radius Shift+B
Edit Paint Effects template brush settings Ctrl+b
Modify Artisan brush Stamp Depth i
Modify Max Displacement [1] m
Modify Value n
Switch to pick colour mode /
Select cluster mode [2] '
Open Paint Effects panel 8
Poly Brush Tool marking menu o+LMB
Poly UV Tool marking menu o+MMB

[1] Of Sculpt Surfaces and Sculpt Polygons Tool
[2] Of Paint Weights Tool

Tumble, Track or Dolly:

Tumble Tool Alt+LMB
Track Tool Alt+MMB
Dolly Tool Alt+RMB

Display:

Shading > Wireframe 4
Shaded display 5
Shaded and Textured display 6
Lighting > Use All Lights 7
Display Quality marking menu d+LMB
Low Quality Display setting 1
Medium Quality Display setting 2
High Quality Display setting 3

Displaying Objects (show, hide):

Display > Hide > Hide Selection Ctrl+h
Display > Show > Show Last Hidden Ctrl+Shift+H
Display > Hide > Hide Unselected Objects Alt+h
Show > Isolate Select > View Selected Shift+I

Tool Operations:

Complete current tool Return
Abort current tool ~
Enter tool Edit mode Insert
Select Tool Shift menu+Q
Component marking Shift menu+Q+LMB
Select tool Alt+q
Polygon marking menu Alt+q+LMB
Mask marking menu q+LMB
Move tool w
Move tool marking menu w+LMB
Rotate tool e
Rotate tool marking menu e+LMB
Scale tool r
Scale tool marking menu r+LMB
Show manipulator tool t
Select last used tool [3] y
Snap Move, Rotate, Scale tool j
Increase manipulator size = or +
Decrease manipulator size -

[3] Excluding Select, Move, Rotate and Scale

Animation Operations:

Animate > Set key s
Insert Keys tool [4] i
Keyframe marking menu Shift+S+LMB
Tangent marking menu Shift+S+MMB
Set key for Rotate Shift+E
Ser key for Scale Shift+R
Set key for Translate Shift+W
Cycle handle stiky state (for IK handles) Alt+s

[4] For Graph Editor

Playback Control:

Move forward one frame Alt+.
Move backward one frame Alt+,
Go to Next key .
Go to previous key ,
Turn Playback on/off Alt+v
Go to Min Frame Alt+Shift+v

Hotbox Display:

Hotbox Space
Default Hotbox Style [5] Alt+m

[5] Zones and Menus Rows

Window and View Operations:

Toogle Attribute Editor and Channel Box Crtl+a
Frame all in active panel a
History Operations marking menu a+LMB
Frame All in all views Shift+A
Frame selected in active panel f
Frame selected in all views Shift+F
Redo view change ]
Undo view change [
Set keyboard focus to command line `
Set keyboard focus to numeric input line Alt+`
Help > Contents and Search F1

Moving Selected Objects:

Move up one pixel Alt+Up arrow
Move down one pixel Alt+Down arrow
Move left one pixel Alt+Left arrow
Move right one pixel Alt+Right arrow

Traversing the Hierarchy:

Walk up the current hierarchy Up arrow
Walk down current hierarchy Down arrow
Walk left current hierarchy Left arrow
Walk right current hierarchy Right arrow

Modeling Operations:

Display coarser Sub-d level Crtl+Up arrow
Select/refine Sub-d component Crtl+Down arrow
Convert poly selection to Vertices Crtl+F9
Convert poly selction to Edges Crtl+F10
Covert poly selection to Faces Crtl+F11
Convert poly selction to UVs Crtl+F12

File Operations:

File > New Scene Ctrl+n
File > Open Scene Ctrl+o
File > Save Scene Ctrl+s
File > Exit Ctrl+q

Selecting Menus:

Show/Hide main menu bar Ctrl+m
Show/Hide panel menu bar Shift+m
Menu Set marking menu h+LMB
Show Animationmenu set F2
Show Modeling menu set F3
Show Dynamics menu set F4
Show Rendering menu set F5

Edit Operations:

Edit > Undo z or Ctrl+z
Edit > Redo Shift+z
Edit > Repeat g
Repeat command at mouse position Shift+G
Edit > Duplicate Ctrl+d
Edit > Duplicate with Transform Shift+D
Edit > Group Crtl+g
Edit > Parent p
Edit > Unparent Shift+P
Edit > Cut Crtl+x
Edit > Copy Crtl+c
Edit > Paste Ctrl+v

Selecting Objects & Components:

Switching between Objevt and Component Editing F8
Select Polygon and Subdivision Surface Vertices F9
Select Polygon and Subdivision Surface Edges F10
Select Polygon and Subdivision Surface Faces F11
Select Polygon and Subdivision Surface UVs F12
Select next intermediate onject Ctrl+i
Select Polygon Vertex/Faces Alt+F9
Shrink polygon selection region <
Grow polygon selection region >






 


